Out for cigarettes
Incident Report for carbn
Update
We are continuing to work on a fix for this issue.
Posted May 01, 2021 - 13:28 CEST
Identified
84% of our human power went out for cigarettes. They have not yet returned.
Posted Apr 25, 2021 - 13:28 CEST
This incident affects: Computation Engine.